faceOSC ——->> wekinator

Welcome Forums Help faceOSC ——->> wekinator

This topic contains 4 replies, has 2 voices, and was last updated by  acookie 7 months, 2 weeks ago.

  • Author
    Posts
  • #510

    acookie
    Participant

    macOS Sierra 10.12.6 (16G29)
    first off wekinator is awesome. But I tried to send data from faceOSC to wekinator and was unable too. I tried changing the ports to 8338. This didnt do anything. I was hoping someone else had some ideas.
    I was doing some research and I have seen a few issues with sierra and faceOSC but nothing substantial.
    Thank you

  • #512

    Rebecca
    Keymaster

    Hi there,

    I’m also on Sierra and FaceOSC works OK for me, so it’s hard to say what is going wrong. I recommend the following:
    1. Make sure you’re running the executable (http://www.doc.gold.ac.uk/~mas01rf/WekinatorDownloads/wekinator_examples/executables/mac/inputs/VideoInput_FacialExpression_oF_14Inputs.zip) rather than from source, in case something has changed in the source on Gene’s github to make it incompatible
    2. Make sure FaceOSC executable draws funny white lines on your face. If it doesn’t, that means it isn’t finding your face. Ensure the data/ directory (which was in the same zip as the executable) remains in the same directory as the executable. (I.e., unzip the file from step 1 and don’t move the executable without the data directory). If you still don’t see white lines, try adjusting your lighting or removing your glasses.
    3. Restart your computer and launch only the FaceOSC executable and Wekinator, and ensure Wekinator is set up to receive 14 inputs. Restarting ensures that there isn’t some other program also receiving OSC.

    Hope this helps.

  • #513

    acookie
    Participant

    Thank you for such a quick response. I tried downloading your version of faceOSC but it crashed as soon as I opened it. I tried this on two machines, the same result occurred on both.

    I am able to see the white lines on my original faceOSC app. I am unable to recieve data in the Wekinator application from -FaceOSC. The OSC In dot in the top left corner remains yellow.

    Should I be placing the face OSC folder inside of a specific location inside of my main openFrameworks folder?

  • #514

    Rebecca
    Keymaster

    Hi there,

    Regarding the problem with the pre-compiled executable, I suspect you are experiencing the same problem as here: http://www.wekinator.org/forums/topic/mac-binaries-failing-for-webcam-inputs/

    There is an issue with openFrameworks-generated apps on High Sierra, specifically having to do with OS X Gatekeeper.

    One easy fix is to move the app to another directory (e.g., to the desktop) and then back. Then try double-clicking on it again. If it’s the Gatekeeper issue causing your problem, this should fix it.

    Rebecca

    • This reply was modified 7 months, 2 weeks ago by  Rebecca.
  • #516

    acookie
    Participant

    thanks, ur awesome, that was the problem.

You must be logged in to reply to this topic.

  •  
  •  
  •  
  •  
  •