OSX trouble opening Wekinator

Welcome Forums Help OSX trouble opening Wekinator

This topic contains 2 replies, has 1 voice, and was last updated by  Cestmoi 1 year, 4 months ago.

  • Author
    Posts
  • #410

    Cestmoi
    Participant

    Using the OSX download I received the error message cannot open application, it would show in the dock briefly then close again. I updated java with no success.

    Uninstalled that and I next tried the Any OS download. Unzipped it, navigated to the folder and ran the java -jar wekimini.jar command.

    From here I received these error details:

    java -jar wekimini.jar
    Exception in thread “main” java.lang.UnsupportedClassVersionError: wekimini/WekiMiniRunner : Unsupported major.minor version 51.0
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637)
    at java.lang.ClassLoader.defineClass(ClassLoader.java:621)
    at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
    at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
    at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
    at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:247)

    Any hints at how I get this running would be much appreciated.

    Thanks in advance

  • #411

    Cestmoi
    Participant

    Also tried chmod +x wekimini.jar on te suggestion of a couple of forums and still return the same error

  • #412

    Cestmoi
    Participant

    DW. I believe it wouldnt run as i’d installed it a couple of directories deep in the applications folder. Cleaned it all out and Reinstalled the OSX version and it has now opened quite happily

You must be logged in to reply to this topic.

  •  
  •  
  •  
  •  
  •